Previous

Protected: Custom Mounts

$45.00
Next

RPG Class Series | Cleric [v1.2]

$25.00
Next Product Image

RPG Class Series | Archmage [v1.3]

$25.00

 

Add 7 Custom Skills and 2 Equipment to your game!

The Archmage class is a subclass of the Mage class that focuses on magical damage.

The Archmage class is a ranged magical damager that takes control over different elements to cast powerful spells.

Slow your enemies down using Blizzard, finish them off with your Meteor Storm!

 

This pack contains:

  • Staff of Archmage (Item Model/MMOItem/MythicCrucible): 7 skills bound
  • Shiny Staff of Archmage (Item Model/MMOItem/MythicCrucible): 7 skills bound
  • Arcane Slash FX (Skill Model)
  • Arcane Slash Hit FX (Skill Model)
  • Blizzard Icicle FX (Skill Model)
  • Blizzard Icicle Impact FX (Skill Model)
  • Cloak of Hastur FX (Skill Model)
  • Chains of Void Chain FX (Skill Model)
  • Chains of Void Portal FX (Skill Model)
  • Meteor Storm Magic Circle FX (Skill Model)
  • Meteor Storm Meteor FX (Skill Model)
  • Meteor Storm Explosion FX (Skill Model)
  • Arcane Devastation Magic Circle FX (Skill Model)
  • Arcane Devastation Bolt FX (Skill Model)
  • Arcane Devastation Thunder FX (Skill Model)
  • 7 skill icons
  • 17 custom sound effects
  • MythicLib custom skills config
  • MMOCore class & skills config
  • MMOItems & MythicCrucible support
  • Emissive skill textures for Optifine
  • Instruction on how to get the equipment in-game
  • Resource pack included
  • ItemsAdder config – Easy Drag & Drop!
  • Oraxen config – Easy Drag & Drop!
  • Skill upgrade function for MMOCore: Upgrade your skill level for higher damage, reduced cooldown, longer duration, etc
    • Ex) Customizable base damage, per-level damage, minimum / maximum damage
  • Party/Guild function:
    • Damages and debuffs only apply to non-party/guild members
    • Heals and buffs only apply to party/guild members

 

Skills:

  • Passive – Arcane Shield (Passive): You form 2 mana shields that block any attack. Your shields regenerate after some time.
  • Basic Attack – Arcane Slash (Left): Fire a magical slash that pierces through enemies.
  • Skill 1 – Blizzard (Right): Summon icicles that fall to the surface, creating an icy aura that slows enemies.
  • Skill 2 – Cloak of Hastur (Shift + Shift): Summon a cloaked shadow creature slowly creeping up from the ground, spreading an aura that gives fear and blindness effect to nearby enemies.
  • Skill 3 – Chains of Void (Shift + Right): Open a void portal on the ground, summoning void chains that strike the surface in front of you 2 times, each time creating a void rupture that pulls in enemies.
  • Skill 4 – Meteor Storm (Hold Shift): Summon multiple meteors fired towards the surface, causing deadly explosions.
  • Ultimate – Arcane Devastation (Shift + Left): Levitate yourself in the air and form an area of destruction where you summon bolts of thunder that stun enemies. After some time, you lunge down to the surface and summon bigger, longer-lasting thunder bolts in a ring, dealing huge damage to nearby enemies, stunning them.

 

You only need one of the three – MMOItems, MMOCore, OR MythicCrucible to make the pack work. You don’t need all of them.

 

Dependencies: MythicMobs, ModelEngine

Tested on version 1.18.2, MythicMobs (5.1.0), MMOItems (6.7.4), MythicLib (1.3.3), MythicCrucible (1.4.0), MMOCore (1.9.4), ModelEngine (R3.0.0), Resource pack included

Tested on version 1.19.4, MythicMobs (5.3.5), MMOItems (6.9.4), MythicLib (1.6.1), MythicCrucible (1.6.0), MMOCore (1.12), ModelEngine (R3.1.8), Resource pack included

Tested on version 1.20.1, MythicMobs (5.4.1), MMOItems (6.9.4), MythicLib (1.6.1), MythicCrucible (2.0.0), MMOCore (1.12), ModelEngine (4.0.3), Resource pack included

 

You will need MythicMobs Premium to use skills with MMOCore/MMOItems (For placeholder function)

Login/Register to purchase this product!

Description

UPDATE [v1.3]

– Added new skill slot function of MMOCore

– Fixed Blizzard skill broken on recent mythicmobs version

UPDATE [v1.2]

– Fixed Oraxen config model path

UPDATE [v1.1]

– Fixed Itemsadder sound issue

 

You only need one of the three – MMOItems, MMOCore, OR MythicCrucible to make the pack work. You don’t need all of them.

 

Dependencies: MythicMobs, ModelEngine

Tested on version 1.18.2, MythicMobs (5.1.0), MMOItems (6.7.4), MythicLib (1.3.3), MythicCrucible (1.4.0), MMOCore (1.9.4), ModelEngine (R3.0.0), Resource pack included

Tested on version 1.19.4, MythicMobs (5.3.5), MMOItems (6.9.4), MythicLib (1.6.1), MythicCrucible (1.6.0), MMOCore (1.12), ModelEngine (R3.1.8), Resource pack included

Tested on version 1.20.1, MythicMobs (5.4.1), MMOItems (6.9.4), MythicLib (1.6.1), MythicCrucible (2.0.0), MMOCore (1.12), ModelEngine (4.0.3), Resource pack included

 

You will need MythicMobs Premium to use skills with MMOCore/MMOItems (For placeholder function)

Additional information

Bundle

No

Discount Specials

No

File Types Included

bbmodel, json, png, yml

Java/Bedrock

Java

Tested Versions

1.18.x, 1.19.x, 1.20.x

Reviews

There are no reviews yet.

Only logged in customers who have purchased this product may leave a review.

You may also like…